Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB Midi Clock runs at 2x or 4x with Deluge
#1
Bug 
I ran into an interesting issue while traveling with my NDLR and my Synthstrom Deluge. If I use USB Host mode on the Deluge to power the NDLR and connect to the Deluge, then the MIDI clock runs at 2x or sometimes 4x the tempo setting on the NDLR. At home, I have everything connected with MIDI cables, and the clock sync works as expected.

I would guess that the NDLR is sending clock messages out on all USB MIDI devices, and the Deluge is interpreting them as coming from the same device (since its USB Host mode doesn’t really support multiple devices).

There are various workarounds, including not connecting USB between the devices, but it is a pretty convenient setup otherwise, in that I don’t have to carry around a separate power supply for the NDLR, and a 5-pin MIDI cable. It’d be nice to have an option on NDLR to not send clock messages to all USB devices, maybe automatically if all parts are routed to USB1, for instance?
Reply
#2
(01-05-2020, 11:25 AM)mbessey Wrote: I ran into an interesting issue while traveling with my NDLR and my Synthstrom Deluge. If I use USB Host mode on the Deluge to power the NDLR and connect to the Deluge, then the MIDI clock runs at 2x or sometimes 4x the tempo setting on the NDLR. At home, I have everything connected with MIDI cables, and the clock sync works as expected.

I would guess that the NDLR is sending clock messages out on all USB MIDI devices, and the Deluge is interpreting them as coming from the same device (since its USB Host mode doesn’t really support multiple devices).

There are various workarounds, including not connecting USB between the devices, but it is a pretty convenient setup otherwise, in that I don’t have to carry around a separate power supply for the NDLR, and a 5-pin MIDI cable. It’d be nice to have an option on NDLR to not send clock messages to all USB devices, maybe automatically if all parts are routed to USB1, for instance?
maybe you can have another result by setting the Deluge Tempo magnitude feature?
Reply
#3
Yes, that would be the symptom of receiving clock on multiple ports. Agree, it would be good to limit which USB port the clock is going out on. I think we already have that on the (very long) to-do list.

We made it go out on all ports because the intention for multiple virtual USB MIDI was to drive multiple stand-alone instruments, each on a different port. This works pretty well in most cases. Totally understand why that would be a problem with a non-PC USB host.

I'm quite impressed that the Deluge sees the 4 ports from The NDLR. They must have a robust USB MIDI implementation. Maybe Daluge can add a parameter to select which MIDI port should receive clock?
Reply
#4
I´ve got the same issue: Receiving Clock via USB on the Deluge which then generates MIDI feedbacks on its MIDI OUT.
Would be helpful if I could switch off the clock and everything else on the USB port so it is a bare power supply
Reply
#5
(03-25-2020, 03:53 AM)racecube Wrote: I´ve got the same issue: Receiving Clock via USB on the Deluge which then generates MIDI feedbacks on its MIDI OUT.
Would be helpful if I could switch off the clock and everything else on the USB port so it is a bare power supply
Hey racecube

There are global menu settings for midi clock as well as usb clock on 1 or all four channels. To access the global menu hold [shift + menu] while powering the NDLR, then select the settings using the 2 motif buttons. finally exit using the panic button to finalize settings and finish boot process. Try setting clock to usb1 only first as I think the issue may be that the Deluge is receiving on all 4 usb channels.

Let me know if that fixes your problem.
Cheers,
Jesse
Reply
#6
My boot menu says:

Pad          :    Factory Reset
Drone      :    C- Lync            (whatever that is??)
Motif 1      :    ClkOut
Motif 2      :      N/A

i am on 1.01.064 and experimented with everything from the above, but there is still MIDI trouble on
USB but I need the clock on 5 Pin

(03-25-2020, 06:15 AM)Jesse Johannesen Wrote: Try setting clock to usb1 only first as I think the issue may be that the Deluge is receiving on all 4 usb channels.
not possible in boot menu and not possible in standard menu, imo
Reply
#7
updated on 1.01.066 now it is possible to switch between USB1 and USB 1to4.....but it does not help in my case.
Reply
#8
(03-26-2020, 04:32 AM)racecube Wrote: updated on 1.01.066 now it is possible to switch between USB1 and USB 1to4.....but it does not help in my case.
Sorry, I should have asked what FW you were on. Since the issue wasn't what I was expecting it to be I had better get more specific info from you as to what you are trying to do. Can you please go into more detail as far as whats sending clock and what's sending midi where? You mentioned wanting to only use the usb as power, have you considered doing just that, as in plug it in to a phone charger (or power bank if you're trying to achieve a mobile setup) and using the 5 pin din you mentioned instead?
Hang in there,
Jesse
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)