Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB sysex issues

I work a lot with SysEx, mainly because I develop editors for various MIDI devices.

I have my MRCC connected to my Mac through the PC USB port and 3 devices connected through the A, B and C USB ports. The devices are:
- Nektar Pacer 
- Waldorf Blofeld
- ASM Hydrasynth

No matter what I try, I can't get sysex messages being sent/received between my Mac and these devices. All other MIDI messages (CC, PC, Notes) go through fine. I checked my setup several times. I also checked that I do not have any filters or other configuration that could be the cause of this problem. I even tried with different cables!

If I connect these devices directly to my Mac, then no problem at all.

I also have a few devices that I don't have a problem with and can exchange messages with without any problem: Arturia Microfreak, Meris pedals.

What is the status of the sysex support in MRCC? Are there any limitations (message length, timing, ...) ?

I really would like to use the MRCC to connect all my hardware. But if sysex support is limited, I think I'll need to find another solution.

Thanks for any help!
If the update involves simply sending a sysex file from the Mac (using Sysex Librarian for example) to the target machine, it should all just work. Some devices need handshaking so you'd have to make sure the To and From routes are set up, but that's about it.

If you are using a 3rd party app like Arturia's MIDI Control Center, those types of updates will not work via USB through the MRCC. From what I gathered talking to Darryl and company is that it has to do with the USB port naming and protocol conventions. The App would have to be made smarter/more generic to have the user define the port rather than looking for the specific device name.

I was disappointed with this as well since I have some gear (Arturia, tc electronics, Electra One, and more) that use their own app on the Mac to communicate with their hw devices and I have to re-cable every time I want to do an update (or in the case of the tc M4000, I cannot use the remote editor).
No, it doesn't work for the synth I listed.

I don't use any special software such as Arturia (even if the MRCC should be agnostic to that).

Sending CC messages, PC messages, Note On, Note OFF work fine, always. This confirm that my routing is configured correctly on the MRCC. I suppose the sysex messages I sent are received by the synth, but it's the synth sysex responses that do not pass through the MRCC, probably because of some timing (some synth answer very fast, within 1-2 ms after having received a sysex request) or some buffer size limitation. I think is more time related than size related because, for example, the Hydrasynth responds very fast but send short messages. But it sends quite a lot of short sysex messages.

I expect the MRCC to be totally transparent and accept/forward any kind of MIDI message. If that is not possible then this is a big problem (at least for me). If you have some MIDI issue you can not be sure if it's your synth, your controller or the MRCC. This can quickly become hard to debug.
Hmm - for the Hydrasynth -- if you are using the ASM Updater, it will not work for the reasons I listed above.

I forget (sold my Hydrasynth some time ago) - can you use MIDI-Ox or Sysex Librarian to send patch banks or is everything done through the Updater app?
One known issue currently is that ports 7-12 ( and maybe the USB host ports as well, I forget at the moment) do not have the ability to pass sysex yet. Steve had to write a communications protocol for those ports to "bit bang" the MIDI data to them and it doesn't yet support Sysex, though the plan is that it will. Is it possible that this is the limitation you are running into here or are we dealing with a different issue?
Thanks all for your answers.

@Jesse: my issue is with the USB ports. I don't think they have the same limitation as the DIN 7-12 ports.

I made some progress! My preset was corrupt. I don't know when and how. But this morning it would not load (see my post about that) and so I did a factory reset on my MRCC.

I'm testing each of my devices individually. Only the device under test is connected to the MRCC. So far, it's better. I can send/receive sysex messages with My Hydrasynth and my Netktar Pacer. I can even use the Hydrasynth Manager without any problem.

I will now begin to connect more than one device on the MRCC. I'm crossing fingers.

I'll keep updating this thread with my test results...
Well, I spoke too quickly.

I can't reproduce my success of a couple of hours ago. Now, again, no sysex messages are transfered. All others messages (CC, PC, Note, clock) go through fine.

Is there any limitations on the PC USB virtual ports and/or the USB IN virtual ports?
So far, I can only get sysex communication between a USB device and my Mac with the following routing:

A1 --> P01
P01 --> A

It's like the sysex support is only available for USB A and PC01.

On the other ports (USB B, C, D, PC > 01) all messages except sysex are transmitted without any problem.

I mainly tested with a Bass-Station 2, a synth that sends a simple sysex response and not too fast (it responds about 20ms after having received the request). I get similar results with my Hydrasynth, my Microfreak and my Nektar Pacer.

To send and receive MIDI message I use and

I'm stuck.

Edit: I will test with another PC (my wife's Macbook Pro). Maybe it's my Mac the problem.
I sold my MRCC. So, no more tests results. Sorry.
There seem to be problems with Sysex. I didn't test or monitor this thoroughly, but when I tried to send a firmware update to my MidiALF (comes as a .syx file) it did not work.
On my other Mac with Alyseum MIDI Interfaces - no problem.
Configuration was: Macbook to MRCC -> DIN Port 1 -> MidiALF
MRCC Version 1.0.30

Forum Jump:

Users browsing this thread:
1 Guest(s)