Conductive Labs Customer Discussion and Support Forum

Full Version: Serious issues with the screen
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just received my brand new NDLR from Perfect Circuit yesterday with the latest firmware preinstalled and have it plugged into a powered USB hub for power and midi to an ipad pro. Everything works fine for a few minutes but then the screen just becomes unresponsive. The knobs and buttons seem to be functioning but the screen seems to be frozen with nothing changing despite any parameter change. Unplug and plug back in and the same behavior is reappearing every time after maybe 10 different attempts.

Side note. I can see a faint red light emitting from underneath the the buttons any time I change a parameter via button or knob. Not sure if that is a normal behavior either. 

Should I just return to Perfect Circuit? Maybe try a different power outlet?
I'm sorry to hear about that. It sounds like a bad screen solder connection, not super common but we've seen it before. The fastest solution would be to return it to Perfect Circuit and get them to send a replacement. They can deal with returning it to us for credit. The red light is normal.
Sorry about that!
Jesse
(09-30-2021, 06:32 PM)Jesse Johannesen Wrote: [ -> ]I'm sorry to hear about that. It sounds like a bad screen solder connection, not super common but we've seen it before. The fastest solution would be to return it to Perfect Circuit and get them to send a replacement. They can deal with returning it to us for credit. The red light is normal.
Sorry about that!
Jesse

Thank you Jesse. I have contacted Perfect Circuit.
(09-30-2021, 06:32 PM)Jesse Johannesen Wrote: [ -> ]I'm sorry to hear about that. It sounds like a bad screen solder connection, not super common but we've seen it before. The fastest solution would be to return it to Perfect Circuit and get them to send a replacement. They can deal with returning it to us for credit. The red light is normal.
Sorry about that!
Jesse

So I tested my NDLR under different scenarios (powered USB hub, wall charger, etc) and was able to reproduce the screen freeze consistently. It would, without fail, freeze after about 5 minutes of use. Unfortunately I sent it back to Perfect Circuit and they had it for almost two weeks until today they are shipping it back unable to reproduce the issues I was having. I'm not sure what my options are if I get it back and it still freezes for me. And I am extremely unimpressed and will never order from Perfect Circuit again with the way they seemed to show no urgency with my RMA.
(10-21-2021, 09:29 AM)Glomewav Wrote: [ -> ]
(09-30-2021, 06:32 PM)Jesse Johannesen Wrote: [ -> ]I'm sorry to hear about that. It sounds like a bad screen solder connection, not super common but we've seen it before. The fastest solution would be to return it to Perfect Circuit and get them to send a replacement. They can deal with returning it to us for credit. The red light is normal.
Sorry about that!
Jesse

So I tested my NDLR under different scenarios (powered USB hub, wall charger, etc) and was able to reproduce the screen freeze consistently. It would, without fail, freeze after about 5 minutes of use. Unfortunately I sent it back to Perfect Circuit and they had it for almost two weeks until today they are shipping it back unable to reproduce the issues I was having. I'm not sure what my options are if I get it back and it still freezes for me. And I am extremely unimpressed and will never order from Perfect Circuit again with the way they seemed to show no urgency with my RMA.

Oh that's bad news. Can you please email me at support@conductivelabs.com and we can figure out what to do over there? Thanks,
Jesse